Doppelte Werte in Microsoft Ecxel markieren

In Microsoft Ecxel doppelte Werte in Spalte A mit Makro anzeigen:

=> Rechtsklick auf Tabellenreiter
=> Code anzeigen
=> Folgenden Code einfügen

————————Begin Makrocode—————————–
Option Explicit

Public Sub Doppelte_Werte_Rot_Markieren()
Dim lngZeile As Long
Dim lngZeilenSprung As Long
Dim strSuchwert As String

lngZeile = Cells(Rows.Count, 1).End(xlUp).Row

For lngZeilenSprung = lngZeile To 1 Step -1
strSuchwert = Cells(lngZeilenSprung, 1).Value
If Application.WorksheetFunction.CountIf(Range(Cells(1, 1), Cells(lngZeile, 1)), strSuchwert) <> 1 Then
Cells(lngZeilenSprung, 1).Interior.ColorIndex = 3
End If
Next lngZeilenSprung

End Sub
————————End Makrocode—————————–

 

=> zurück zu Excel unter: Datei -> Schließen und zurück zu Microsoft Excel
=> Extra -> Makro -> Makros oder Alt+F8 drücken
=> Makro namens Doppelte_Werte_Rot_Markieren auswählen und auf Ausführen klicken

In Microsoft Ecxel doppelte Werte in Spalte A ohne Makro anzeigen:

Diese Version geht bei grossen Datensätzen schneller und lässt sich einfacher umfangreich erweitern.

=> In Spalte B einfügen: =WENN(A2=A1;1;0)
=> Ganze Tabelle markieren und Daten -> Sortieren -> nach Spalte A -> Aufsteigend oder Absteigend
=> Spalte B markieren => Format -> Bedingte Vormatierung: Zellenwert ist größer als 0 und z.B. roten Hintergrund wählen und okay klicken

Doppelte Einträge in Microsoft Ecxel markieren

Veröffentlicht unter Microsoft Office
One comment on “Doppelte Werte in Microsoft Ecxel markieren
  1. Malibu sagt:

    So einfach. Nur drauf kommen muss man. Danke für die super Lösung ;-)

Hinterlasse eine Antwort

By continuing to use the site, you agree to the use of cookies. more information

The cookie settings on this website are set to "allow cookies" to give you the best browsing experience possible. If you continue to use this website without changing your cookie settings or you click "Accept" below then you are consenting to this.

Close